WindowChrome bug on retina display

WPF Studio, Themes, and Shared Library for WPF Forum

Posted 6 years ago by Morten
Version: 13.1.0580
Environment: Windows 8 (64-bit)
Avatar

Hi!

On high resolution retina displays (2880x1800) actipro windows get a 6px wide black border around them. Also the 1px light border around the window looks a bit ugly in the top/top-left corner.

See attached screenshot:

http://bildr.no/image/1434773.jpeg

 

Also checked if visual studio has this problem, but visual studio looks good:

http://bildr.no/image/1434774.jpeg

 

Not a critical bug, but wanted to let you know.

Thanks!

Comments (6)

Posted 6 years ago by Morten
Avatar

Looks like the images I posted got really small when using the direct links. Full resolution images can be found on these links instead:

http://bildr.no/view/1434773

http://bildr.no/view/1434774

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Morten,

Can you supply us with exact details about your operating system and DPI and theme settings in Windows so that we can try to reproduce it?  Thanks!


Actipro Software Support

Posted 6 years ago by Morten
Avatar

- Windows 7 Professional on a MacBook Pro Retina (BootCamp)

- Windows 7 Aero Theme

- both Bigger DPI (150%) and Smaller DPI (100%)

- Desktop resolution: 2880x1800

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Odd, I tried it with Windows 7 Aero, 100% DPI and it looked ok for me.  Are you sure you're on the latest version?


Actipro Software Support

Posted 6 years ago by Morten
Avatar

Yes, I'm using the latest version, but turns out I was wrong about the DPI setting.

Tried it on the MacBook Pro again today and I can see it happen with 150% DPI and with all resolutions I've tried (2880x1800, 1920x1200, 1920x1080, etc)

On 100% DPI it looks good in all resolutions.

 

Sorry for the mistake, just thought I tried both DPI settings. :)
I don't use this computer regularly and it was set at 150% DPI when I got it. I remember trying to change the setting to 100%, but probably cancelled that the last time I tried because windows makes you log off when changing it.

Answer - Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Morten,

Thanks for reporting this, I believe we've tweaked it to fix the problem for the upcoming maintenance release in a couple weeks.


Actipro Software Support

The latest build of this product (v2018.1 build 0675) was released 11 days ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.