Backstage Scrollbars Do Not Show Up When DPI not 100%

Ribbon for WPF Forum

Posted 6 years ago by Joe Chura
Version: 13.2.0590
Environment: Windows 7 (64-bit)
Avatar

When using the backstage menu in the ribbon, if your machine is not currently set at 100% for DPI the scroll bars do not display.  You are not able to view/select some of the BackstageTabs or Buttons.

 

Thanks,

Joe

Comments (9)

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Joe,

I just tried this in the latest code and it worked fine for me.  Please tell us which version you are on, and exactly how to repro it in our samples.  If you aren't on the latest version, please try the latest also.


Actipro Software Support

Posted 6 years ago by Joe Chura
Avatar

We have 2013.2.0582

Sometimes it takes us a little bit to update to the latest version.  I will try this again when we get the latest.

 

However, to reproduce this:

Go into Control Panel -> Appearance and Personalization -> Display and set to "Medium - 125%" and restart the machine

Start the application after the restart and open the backstage.  When you resize the window the scroll bar doesn't work correctly and not all of the buttons/tabs are visible to the user.

 

Thanks.

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Joe,

I tried that 125% setting and it worked fine for me in that too.  Please let us know what you find when you try the newer version.


Actipro Software Support

Posted 5 years ago by Joe Chura
Avatar

We actually were able to finally upgrade.  We see the scrollbars show up at 96 dpi and 144 dpi, but they are still not showing up for 120 dpi.  I can send a screen shot if you are interested in seeing an example.

Posted 5 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Joe,

Thanks, feel free to post your screenshot, but we really need to be able to repro it here to be able to do anything.  Can you give exact steps to repro it?  Per our reply a couple months back, we weren't able to, at least in the 125% setting.


Actipro Software Support

Posted 5 years ago by Joe Chura
Avatar

Sorry for the long delay.

To reproduce this we went to: Control Panel -> Appearance and Personalization -> Display and set to "Medium - 125%" which will prompt a restart.

After restarting we went into our application and opened the Backstage.  We then resized the application window so that it was smaller than our Backstage (Buttons and BackstageTabs).  We were unable to access the items on the bottom of the backstage menu because the window was too small and there was no way to scroll the overall backstage contents.

Hope this helps,

Joe

Posted 5 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Joe,

Odd, I'm running my Surface Pro at 125% and can see the Backstage scrollbars ok in our main Ribbon demo.  Are you sure you're on the latest build of our controls?  Can you repro it with our main demo?


Actipro Software Support

Posted 5 years ago by Joe Chura
Avatar

We are using the latest build.  I was not able to reproduce it in your demo.  However, we are using the ThemeName.OfficeSilver theme.  I'm not sure if this has an effect on the layout, but we are still experiencing the problem.

Thanks, Joe

Posted 5 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Joe,

Can you email us a new simple sample project that shows the issue ASAP?  We are hoping to do a maintenance release very shortly, so it would be nice to debug this beforehand.  Please send it to our support address, reference this post, and rename the .zip file extension so it doesn't get spam blocked.  Thanks!


Actipro Software Support

The latest build of this product (v2018.1 build 0675) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.