Black area when RibbonWindow is maximized

Ribbon for WPF Forum

Posted 6 years ago by Ilian Pinzon
Version: 13.2.0591
Platform: .NET 4.5
Environment: Windows 7 (64-bit)
Avatar

Hi Guys,

RibbonWindow does not maximize correctly when the display configuration is changed. We noticed this when we docked a laptop onto a docking station with a bigger monitor than the laptop's.  The window will not maximize to the full extent of the monitor and a black area will appear as seen below:

 

It is also possible to reproduce the behavior on a desktop machine with two monitors of different sizes (I used one with 1920x1200 resolution and 1600x1200). Here are the steps:

  1. Make the bigger monitor as the main display (Right click desktop -> Screen resolution -> Select monitor -> Tick "Make this my main display")
  2. Turn off the bigger monitor
  3. Run Actipro WPF Control Sample Browser
  4. Turn on the bigger monitor (application should move to bigger monitor automatically)
  5. Press the maximize button and black area should appear

Also, I could not reproduce this behavior when running the default vanilla WPF project from Visual Studio.

[Modified 6 years ago]

Comments (7)

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Ilian,

What exact version/build are you on and have you tried this with the latest version?

Also please explain exactly what you mean by turn off/on the bigger monitor.  Do you mean via its power button or something else?


Actipro Software Support

Posted 6 years ago by Ilian Pinzon
Avatar

Hi,

Latest version - 13.2.0591. Windows 7 x64 with .NET 4.5.

Yes. Turning it off using the power button will reproduce the bug.

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Ilian,

I'm sorry but I can't repro this.  When the bigger monitor is off (and I hear the sound from Windows indicating a device is now gone), it still opens windows to that display.  Nothing moves between monitors for me when they are turned on and off.  And this is the same for other non-WPF based windows as well, at least on my system.  I'm on Windows 8 x64 so there must be some setting somewhere that controls this.  But I haven't found one in Windows.


Actipro Software Support

Posted 6 years ago by Ilian Pinzon
Avatar

Hi,

We can reproduce this consistently on Windows 7 machines here.

Just asked my colleague to try it on his Windows 8.1 machine and he's able to reproduce it without using an extra monitor. Here are the steps:

  1. Just use a machine with one monitor
  2. Change the resolution of the monitor to the lowest setting possible
  3. Run Actipro WPF Control Sample Browser  (make sure it is not maximized)
  4. Change the resolution to the highest setting
  5. Maximize Actipro WPF Control Sample Browser

Also I looked at the other reported issues and I have a feeling that this is related to: http://www.actiprosoftware.com/community/thread/21326/restricted-width-of-ribbonwindow

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Ilian,

I can see it happening with that scenario.  I spent a while on this and narrowed it down to the changes in 2013.2 where we added a handler for the WM_GETMINMAXSIZE windows message.  The reason we added this was so that our chromed windows wouldn't cover up an auto-hidden Windows taskbar.

I tried a number of things but wasn't able to make any progress on it thus far.  I even made a new simple sample project that doesn't use our controls at all and just handles that WM_GETMINMAXSIZE message and shows the same behavior on a standard WPF window.  If you would like to contact our support email address and reference this thread, I'll be happy to send it to you and perhaps we can work together to find a way to still handle that Windows message but not have this negative side effect.


Actipro Software Support

Posted 6 years ago by Valéry Sablonnière - Staubli
Avatar

Hello,

I have the same strange behavior when I do this:

  • I set the resolution of my screen to 800x600
  • I run the Actipro Software WPF Controls Sample Browser
  • I set the resolution of my screen to 1600x1200

Now if I maximize the Sample Browser, there are big black borders on the right and on the bottom.

Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello, that is the same issue as described above.  It seems to only happen when there is a single monitor too.  We still haven't been able to find a workaround for it, other than removing the WM_GETMINMAXSIZE handler (which was added so that chromed windows won't cover up an auto-hidden taskbar).

If you'd like the sample we mentioned in our previous reply, where we can repro it just with a regular WPF window, please write our support address and reference this thread.


Actipro Software Support

The latest build of this product (v2019.1 build 0681) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.