Do I need a new Antlr runtime?

SyntaxEditor for WPF Forum

Posted 6 years ago by Taraneh Maleki
Version: 13.2.0592
Avatar

I just upgraded to ActiproSoftware.SyntaxEditor.Wpf, Version=13.2.592.0,   I am getting an exception :

Could not load file or assembly 'Antlr3.Runtime, Version=3.4.1.9004, Culture=neutral, PublicKeyToken=eb42632606e9261f' or one of its dependencies. The system cannot find the file specified.

 

Any ideas what I need to do ?

Comments (2)

Answer - Posted 6 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Taraneh,

That assembly is only required if you are including the ANTLR parser integration assembly we provide.  If you don't use ANTLR, then you shouldn't be referencing the ActiproSoftware.Text.Addons.Anltr.Wpf.dll.  My guess is that you referenced that assembly by accident, and that removing the reference to it will solve your problem.


Actipro Software Support

Posted 6 years ago by Taraneh Maleki
Avatar

Thanks , that solved my problem

The latest build of this product (v2019.1 build 0683) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.