Korean Language Bar Does Not Work in C# Editor

SyntaxEditor for Silverlight Forum

Posted 5 years ago by Kevin Woo
Version: 11.2.0121
Platform: Silverlight 4
Avatar

I am using the Lanuage Bar to select my language as Korean with Microsoft IME keyboard (Korean Keyboard causes confusion and should not be installed).  There is a button to click to switch from Han/Eng.  For Microsoft Word, Notepad, and other Windows Forms applications when I click this button Korean is typed.  However, when I have the SyntaxEditor for Silverlight as the application the button to switch to Han/Eng is greyed out and only english is available.  Does anyone know why this would happen?  I am able to copy and paste Korean from Notepad to the editor but not type it in directly.

Best Regards

Comments (1)

Posted 5 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello,

Since SyntaxEditor is a custom control and Silverlight doesn't expose IME support to custom controls, it's likely that Silverlight thinks that SyntaxEditor can't accept IME input and thus grays out the switch option.  Unfortunately I'm not sure what we can do about this since it doesn't appear that custom controls in Silverlight have any API available to them to support IME.  There is an attached property that Microsoft has in the Silverlight API that can set an input method enabled state, but it doesn't seem to have any effect for custom controls and only affects TextBox/RichTextBox.


Actipro Software Support

The latest build of this product (v2018.1 build 0232) was released 6 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.