Cannot add reference to the ribbon dll in vs2005

Ribbon for WPF Forum

Posted 12 years ago by John Taylor
Version: 1.0.0326
Avatar
Has anyone else had an issue with adding a reference to the Ribbon and shared dlls?

When I click on 'Add Reference', the actipro GAC dlls don't appear in the .Net tab.
When I browse to the GAC [c:\windows\assembly] I can see the assemblies, but when I select them nothing happens!

Any ideas?

Comments (8)

Posted 12 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hmm, it should work ok. Try adding them from the file locations in the Program Files folders that is indicated in the Readme. Let us know if that gets it working for you.


Actipro Software Support

Posted 12 years ago by John Taylor
Avatar
That works...but i'm wondering why I can't add them from the Gac?, the other Gac dlls get added no problem

p.s. I've re-booted since the install
Posted 12 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi John,

I've investigated this and it appears that the Shared library's registry entry that tells VS where the assembly is located didn't have the correct path. We'll get this resolved for the next release. Thanks for the heads up!


Actipro Software Support

Posted 12 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
FYI, this should be fixed in today's release.


Actipro Software Support

Posted 12 years ago by John Taylor
Avatar
Sorry chaps, still doesn't work :(

They appear in the GAC when you browse to c:\Windows\Assembly but can't be added.
Posted 12 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi John,

In the current build that came out yesterday, when I open the Add Reference dialog in VS, I see "Actipro Ribbon" and "Actipro Shared Product Base Library". You are saying you don't see those? If not, please email us and we can try and work with you to find out why not.

In the build before the current one, the shared library didn't have the path correct in the registry and wasn't showing up in the list. But I do see it now.


Actipro Software Support

Posted 12 years ago by John Taylor
Avatar
Doh!...my bad
The last version sorted it, I was just being stoopid.
Posted 12 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Phew, I was worried there for a bit. :)


Actipro Software Support

The latest build of this product (v2018.1 build 0675) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.