Odd Behavior for Scrolling Split View

SyntaxEditor for Windows Forms Forum

Posted 15 years ago by Boyd - Automated Software Testing Consultant / Developer, Patterson Consulting, LLC
Avatar
I've noticed some unexpected behavior when scrolling the splitters for managing the vertical and horizontal split views.

When splitting is supported and the split isn't currently active, there is a draggable bar that allows you to instantly split the screen. This bar appears at the top of the veritcal scrollbar and to the right of the horizontal scrollbar.

When you drag the bar to activate horizontal splitting, you drag from the top. To turn off splitting, you can drag the bar back off the top of the document view to make the splitting go away. This makes sense and operates just like Whidbey.

When you drag the bar to activate vertical splitting, you drag from the right. To turn off splitting, I would think that you could grag the bar back off to the right of the document view to make the splitting go away. This doesn't work. Instead, this technique is performed by scrolling it all the way over and off the left side of the document view. This isn't consistent with how the horizontal splitter works.

I know double-clicking the splitter will also make it go away, but this behavior is still odd.

If there's a property that controls this, I apologize for overlooking it and would appreciate it if you could bring it to my attention. If not, could you please modify this behavior in the next release to make it more consistent? Thanks!!

Comments (1)

Posted 15 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Yes we're aware of this. In the 2.5 release we've already moved the bottom split button to the left side of the scrollbar instead of the right. That way it is more consistent.


Actipro Software Support

The latest build of this product (v2018.1 build 0341) was released 7 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.