PropertyGrid and BuiltinPropertyEditors in new UPW components 18.1.332.0

Editors for Universal Windows Forum

Posted 4 months ago by Jindrich Nikodem
Version: 18.1.0332
Avatar

Hello friends,

I am using PropertyGrid for editing own classes. In version 18.1.330.0 I was use the attributte for BuiltinPropertyEditors.IsEnabled = "True" for my PropertyGrid. This worked right e.g. for numeric properties. But in the version 18.1.332.0 if I use attributte BuiltinPropertyEditors.IsEnabled, then the PropertyGrid shows for all properties of my class bad values and editors not work. All properties in the PropertyGrid is not possible edit.

Here is my sample code:

https://1drv.ms/u/s!AnJ2aWuw6GeLk_wiOTSVatptOzg_hg

Please, can you help me.

Thank you very much.

Best Regards.

Jindrich

Comments (2)

Posted 4 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello,

We are still looking into what is causing this.  It's not been easy to debug since it works fine when we directly reference our source projects instead of the production SDK.  We will update this thread when we have more info.


Actipro Software Support

Posted 4 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello,

Can you please write our support address and mention this thread?  We'd like to send you a preview build to test with.  Thanks!


Actipro Software Support

The latest build of this product (v2019.1 build 0340) was released 6 days ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.