Syntax Editor IME-related, Korean Is Available??

SyntaxEditor for WPF Forum

Posted 3 months ago by SUMIN KIM
Version: 19.1.0682
Avatar

Hi.

I'm using a very old version (4.0.0282 release)

There's a problem with using Korean, maybe IME.

When I looked at the forum, I saw an article about 10 years ago stating that IME support is not due, but is it still not available in the latest release?

The current status issue is character becomes smaller or you don't see the last character you typed.

And we have similar issu when we use Japanese, is it possible to solve the problem with the latest release?

+ I tried the latest release demo and Korean didn't do well.

++ According to the forum's data seven years ago, Japanese people were solved through code example. Is that possible now?

+++ How do I set font and font size?

Sorry for asking too many questions, difficult questions at once.
I'll wait for your answer.

Comments (5)

Posted 3 months ago by SUMIN KIM
Avatar

Syntax Editor in "Windows Forms Controls" the Korean is operating normally.

Posted 3 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello,

I'm sorry you're having trouble.  First, I want to make sure I understand the platform correctly.  You posted this in the WPF SyntaxEditor forum but you mentioned v4.0 (which was WinForms) and Windows Forms.  Please let us know, are you currently trying the WPF or WinForms version of SyntaxEditor where you are seeing problems?

1) Can you tell us exactly how to reproduce the problem, step-by-step in one of our samples, so that we can see what you see?

2) Can you post a link to the forum thread you mentioned regarding the Japanese issue?

3) If you mean the font in the editor control, in WPF, you'd set the SyntaxEditor.FontFamily and FontSize properties.  In WinForms, you'd set the SyntaxEditor.Font property.  Or do you mean something else?


Actipro Software Support

Posted 3 months ago by SUMIN KIM
Avatar

Thank you so much for your quick reply.

The platform I inquired about is "WPF SyntaxEditor," right.
WinForm is just what I tested.
*WPF SyntaxEditor - Topic of My Questions, Error in Korean input.
*WinForm - just test, Korean input works normally.

1) Can you tell me an email to send an image to the answer to this question?

2) I don't know if it's relevant, but this is the forum I saw
https://www.actiprosoftware.com/community/thread/20071/ms-ime-cannot-be-input-in-adoner-textbox-of

3) I think it's settled. Thank you.

[Modified 3 months ago]

Posted 3 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello,

1) You can write our support address listed here.  Please reference this thread in your e-mail and include step-by-step instructions of what you see in WPF (with the error) compared to what you see in WinForms (where it's working).

2) Thank you, I see the code change that was made in that related thread.  Part of that was changed when we refactored SyntaxEditor in the 2019.1 version.  I wonder if that may be contributing to this problem.  If you can tell us how to reproduce the problem per above in #1, we will dig in and see if those recent changes caused it.


Actipro Software Support

Posted 3 months ago by SUMIN KIM
Avatar

Please check email.

I sent an explanation and an image of the relevant content.
If there's something you don't understand, please do me a reply.

The latest build of this product (v2019.1 build 0683) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.