QAT images of commands are messed up after theme change or disabling using CanExecute

Ribbon for WPF Forum

Posted 6 months ago by Martin de Jong - Statistics Netherlands
Version: 19.1.0684
Platform: .NET 4.7
Environment: Windows 10 (64-bit)
Avatar

Hi,

We have a little problem. In our QAT are a few ribbon commands added. When we change the theme, while the application is active, from Metro Dark to one of the Metro Light ones, the icons getting (bright) white. Even disabling and re-enabling the commands (using CanExecute) gives strange white icons. Or activating the backstage. Changing to another Metro Light theme does not solve the problem..

If we start the application with any theme everything is ok at first, but focussing backstage makes icons white again.

Do you have an idea what this is causing?

Greetz Martin,

(Yes, working from home:))

[Modified 6 months ago]

Comments (2)

Posted 6 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Martin,

It sounds like it might be thinking that an accent title bar is in use since it will transform QAT icons to white in that scenario.  Can you give us steps to reproduce this in one of our samples?


Actipro Software Support

Posted 6 months ago by Martin de Jong - Statistics Netherlands
Avatar

After i assigned ImageSourceSmall to the (split)Buttons themselves, problem seems to be solved. So the use of the RibbonCommand images caused some visual affects;)

The latest build of this product (v2020.1.0) was released 17 days ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.