Menu sub-items hot keys are ignored

Docking/MDI for WPF Forum

The latest build of this product (v21.1.1) was released 1 month ago, which was before this thread was created.
Posted 6 days ago by Michael Janulaitis
Version: 21.1.1
Platform: .NET 4.8
Environment: Windows 10 (64-bit)
Avatar

It seems to me this is a bug in the native WPF control however MS has verified the hot keys on sub-menu items works using a stack panel.  The keyboard focus remains in controls contained within the tool windows, specifically a text box control.  The menu item does not get the keyboard focus.  Possibly the docking control is causing this issue?

Comments (3)

Posted 5 days ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello,

I'm sorry you're having trouble.  We're not aware of any menu item issues.  Can you tell us exactly how to reproduce this in one of our samples?  And just to verify, you are on .NET 5?


Actipro Software Support

Posted 5 days ago by Michael Janulaitis
Avatar

I am on .Net 4.8.  Sorry about the misunderstanding. I wasn't able to change after I noticed I submitted it incorrectly.  I modified your project and it works.  I would like to do a remote session so I can show you in my project.

Posted 5 days ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Michael,

No problem, I adjusted it to say .NET 4.8.  Unfortunately remote sessions aren't generally helpful in solving problems.  What would be best is if you can reproduce this in a new simple sample project and email that to our support address, mentioning this thread.  Then we can debug with that and see what's going on.  Please keep it as minimal as possible and remove the bin/obj folders from the .zip you send so it doesn't get spam blocked.  Thanks!


Actipro Software Support

Add Comment

Please log in to a validated account to post comments.