WindowChrome Windows 11 Support in 22.1 not working for me

WPF Studio, Themes, and Shared Library for WPF Forum

The latest build of this product (v22.1.0) was released 1 month ago, which was before this thread was created.
Posted 1 month ago by Oliver Fink
Version: 22.1.0
Platform: .NET 5.0
Environment: Windows 10 (64-bit)
Avatar

Hi there, I'm evaluating WPF for upgrade and was happy to see that integration with W11 should be there (as per the blog article https://www.actiprosoftware.com/blog/post/25678/wpf-controls-v221-released ).

However, I don't see the Snap UI on the maximize/restore titlebar buttons in either the Demo applications or simple quickstart. I've doublechecked that version 22.1 and tried it with both netcore-6/netcore-5 and framework-4.7.2 targets.

public MainWindow()
{
   InitializeComponent();
   WindowChrome.SetChrome(this, new WindowChrome());
}

It might be that I'm missing something super obvious, but it doesn't show for me (Windows 11 Pro, 22000.376)

Any ideas?

Comments (2)

Answer - Posted 1 month ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Thank you for your post. We identified an issue with the logic used to detect if snap layouts are enabled and the fix will be in the next maintenance release.

To get them working on the current release, you should just need to toggle snap layouts off and back on. You can access the setting from Windows Settings > System > Multitasking > Snap windows > Show snap layouts.  This will create the registry value  "EnableSnapAssistFlyout" under key "Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced" that indicates if snap layouts are enabled. This key is not present, by default, on a new install until the setting is modified at least once, and we incorrectly had the feature default to being disabled if the value was not defined in the key.


Actipro Software Support

Posted 1 month ago by Oliver Fink
Avatar

Great! Yes, I can confirm that this was the problem. Toggling the setting created the registry entry and now it's showing for me as well. 

thanks for the quick response!

O

Add Comment

Please log in to a validated account to post comments.