Problem when maximizing the mainwindow

Docking/MDI for WPF Forum

Posted 10 months ago by Patrick Neubauer
Version: 22.1.0
Platform: .NET 5.0
Environment: Windows 10 (64-bit)
Avatar

Hi there,

we found a problem when using 2 displays. The small one (e.g. resoultion 1920*1080) must be the primary display. The big one (e.g. 3840*1600) must be the secondary display.
When minimizing and maximizing the application in the big screen then the size of in the application is not maximized. 
This can be reproduced using the sample browser. 

Best Regards, 
Patrick

Comments (3)

Posted 10 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Patrick,

Thank you for reaching out. We've tried with multiple developers and machines, but we have not been able to reproduce what you are describing. Could you please provide a little more detail to help us try to reproduce?

  1. Confirm the Actipro controls are v22.1.0.
  2. Can you confirm this is only on Windows 10 or have you also seen it on Windows 11? Our multi-monitor development machines are all Windows 11 at this point.
  3. Have you been able to reproduce on .NET Framework, or only with .NET 5? What about .NET 6?
  4. Are there specific steps that must be performed to reproduce the issue, or is just minimizing and maximizing on the larger monitor all that is necessary?
  5. Does it only happen when running in the Visual Studio debugger, or can you reproduce without the debugger attached?
  6. What is the relative position of the small and large monitor. For example, are they positioned side by side with the primary (smaller) on the left and secondary (larger) on the right?

Any additional details you think are relevant to reproducting what you described are also welcome.


Actipro Software Support

Posted 10 months ago by Patrick Neubauer
Avatar

Hi,

1. the problem can be reproduced using the v22.1.0 or older Actipro controls.

2. I have not seen it on Windows 11. 

3. I was able to reproduce it on .NET Framework. I haven´t tried .NET 5 or .NET 6.

4. No there are no specific steps to reproduce the issue. Just minimizing and maximizing on the larger monitor.

5. It can be reproduced without the debugger attached.

6. They are positioned side by side with the smaller on the right and the larger one on the left.

The problem can only be reproduced on one machine. This machine is using a Intel UHD 630. 

Best Regards, 
Patrick

Posted 10 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Thank you for the additional details. We don't have access to that exact configuration, but I did try to reproduce on Intel HD 520 graphics under Windows 10 and .NET Framework using the Sample Browser application installed with v22.1.0. I configured the larger (secondary) monitor to the left of the smaller (primary) monitor and tried both 100% and 150% DPI settings on the larger monitor. I launch the Sample Browser application which starts unmaximized. I then maximize the window, minimize, and repeat maximize/minimize a few times. I have not been able to reproduce any issues with the window not sizing properly when maximized.

You mention this can only be reproduced on one machine. Oddities have been known to happen if the .NET Framework files become corrupted, so you may want to consider re-installing the proper version of the .NET Framework. Trying with .NET 5 or 6 might also help isolate if this is an issue with .NET Framework or a broader issue with the machine configuration.

If you have any window management software running that helps automatically position windows on wide resolution monitors like what you specified as your secondary monitor, that could also be interferring with "normal" window maximization logic.

We have not had any other reports of this issue after many years of availability on Windows 10, so I suspect this is something unique to that machine configuration.


Actipro Software Support

The latest build of this product (v22.1.4) was released 23 days ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.