Wizard not showing pages in design mode in VS2022

Wizard for Windows Forms Forum

Posted 2 months ago by AF
Version: 22.1.0
Platform: .NET 4.7
Environment: Windows 10 (64-bit)
Avatar

Note: This works fine in VS2019 on same PC.

Environment:
- O/S Windows 10 x64
- Microsoft Visual Studio Professional 2022 v17.1.0

Steps to reproduce:

1. Install Actipro WinForms Controls v22.1.0
- deselect option to add GAC Assemblies

2. Open SampleBrowser.sln in VS2022

3. Open ProductSamples\WizardSamples\Demo\Features

4. Form opens but does not show page content and the 'Next >' button does not move to the next page.

Also, no verbs are showing at bottom of properties Window.

I tried uninstalling and reinstalling with same issue.

Comments (2)

Answer - Posted 2 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Thank you for reporting this and providing the steps to reproduce. The WinForms designer story gets really messy with Visual Studio 2022. Not only does it have totally different designers for .NET (Core/5/6) compared to .NET Framework, it also has a 64-bit IDE for the first time.

When our controls are installed, we add several registry entries under the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319\AssemblyFolersEx

The sub-keys in that folder instruct Visual Studio where to find our assemblies and how they should be loaded in the Visual Studio Toolbox. It also tells Visual Studio where to find the design assemblies that correspond to our control assemblies.

Since our installer is a 32-bit process running on a 64-bit host, the registry keys actually get virtualized and created at the following key instead of the one above:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319\AssemblyFolersEx

Now that Visual Studio is 64-bit when it reads the registry, it is not reading from the "WOW6432Node" like it did with Visual Studio 2019 and prior versions. Since our control assemblies are still loading properly in the Toolbox, Microsoft at least worked around part of this. It appears, however, that they have not applied a similar work-around for resolving the design assemblies.

When you install the assemblies to the GAC, those assemblies get used by the designer and it finds the corresponding design assemblies in the "Design" sub-folder.

I'm not 100% certain on this, but I believe Visual Studio 2022 creates "shadow copies" of assemblies to be used for the designer, and it must only be copying our control assemblies without also copying the design assemblies into a "Design" sub-folder. When the designer attempts to find the design assemblies, it can't find the sub-folder and also can't find an entry in the registry to tell it where those assemblies are. End result is no designer functionality.

Aside from the workaround of installing to the GAC, I have verified that adding the following registry key (not in the "WOW6432Node") will also work to inform Visual Studio 2022 where to find the design assemblies.

Add the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319\AssemblyFoldersEx\Actipro WinForms Controls v22.1 Design

Then set the "(Default)" value to installation folder of the design assemblies (default path shown):

C:\Program Files (x86)\Actipro Software\WinForms-Controls\v22.1.0\Assemblies\Design

We will work internally on a potential fix for this in a future release and will communicate with Microsoft about a possible update to Visual Studio. Please let us know if the registry workaround does not resolve the designer issue for you.


Actipro Software Support

Posted 2 months ago by AF
Avatar

Yes, adding the registry entry works.

Thanks

The latest build of this product (v22.1.2) was released 1 days ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.