Strange ribbon window bug (sizetoContent)

Ribbon for WPF Forum

Posted 11 years ago by Michael Rösslhumer
Version: 3.5.0429
Platform: WPF Controls
Environment: Windows XP (32-bit)
Avatar
Hi Actipro-Team
I have found a strange behaviour when i use RibbonWindows with SizeToContent property set to Width, Height, WidthHeight. On every window there is a strange black border available - for me it looks like a bug.

This bug is also active in your sample Application. You can have a look at "Window Size to Content" sample.

How can i get a workaround or fix for this bug.

Kind regards
Michi

Comments (6)

Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Michael,

I'm running the v4.0 Window Size to Content" sample in XP and am not seeing anything wrong. Could you email our support staff with a screenshot? Also please confirm this is in XP and not Vista.


Actipro Software Support

Posted 11 years ago by Michael Rösslhumer
Avatar
Size to conent sample works in XP, but do not work correctly under Vista. The strange behaviour i described above only appears on windows vista pcs.
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Michael,

Thanks, yes there does appear to be an issue when using auto-size to height in Vista. This apparently is due to some of the things we have to do to allow WPF controls (app button, QAT, etc.) to draw in the non-client area of the Window. Microsoft makes it extremely difficult to work with drawing in the non-client area of glass windows.

Note that sizing to width will work fine. Also the height does snap back correctly after an adjustment to the size of the Window. We are looking into a way around this issue.

But in the meantime, you can use size to Width only, but should probably avoid WidthAndHeight until the problem is solved.


Actipro Software Support

Posted 10 years ago by Simon Deguire
Avatar
Is this bug fixed now?
Posted 10 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Simon,

Sorry not yet, it's one of the things that has been put off to post-v5.0 release, but is high on the priority list.


Actipro Software Support

Posted 10 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
A fix for this issue is now in place for the next maintenance release.


Actipro Software Support

The latest build of this product (v2018.1 build 0675) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.