Xsd sequence not showing correctly in IntelliSense

SyntaxEditor Web Languages Add-on for Windows Forms Forum

Posted 11 years ago by Michael Giovinazzo
Version: 4.0.0275
Avatar
I have an xsd file that contains a definition for elements to be a specific order or sequence. So in element A you could have one or more of D, E, B, or C in that specific order.
When I setup the editor with the schema I notice 2 things which may be incorrect.
First, When I am inside an empty element A and IntelliSense comes up, I would hope to see the choice of elements D, E, B and C in that order. Instead they show up in alphabetical order.
Second, when I have already added some elements I would expect to only see the elements available after the previous one. So if in element A I already have element B, then if I type '<' after element B I would expect to only see the option of element C in IntelliSense.

We see this as a fundamental problem with the Web Language product. The IntelliSense prompt shouldn't list items that will be invalid.

Michael

Comments (3)

Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Thanks for the note Michael, I'll add this to the TODO list.


Actipro Software Support

Posted 11 years ago by Michael Giovinazzo
Avatar
Thanks for the response. We are currently using your evaluation and we need this functionality. Does TODO mean it will be handled before the next release? Or do you have a time frame on when this will be fixed?

[Modified at 08/26/2008 02:23 PM]
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Michael,

It's hard to say right now. We're in the middle of trying to finalize and roll out a new product, along with making updates to the .NET Languages Add-on at the moment. We'll try and get to it but at this time I can't give you a definitive timeframe.


Actipro Software Support

The latest build of this product (v2018.1 build 0341) was released 10 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.