Posted 11 years ago by Scott Currie
Version: 4.0.0280
Platform: .NET 3.5
Environment: Windows Vista (64-bit)
Avatar
When I specify HeaderText and FooteerText for the XML add-on editor project, all of my validation error squigglies show up in the wrong place (line/char both wrong). Is this a known issue? Is there a workaround?

Thanks,
-Scott

Comments (9)

Posted 11 years ago by Scott Currie
Avatar
I found a workaround. The error squigglies only show up in the correct place when the header and footer text blocks have a newline character at the end and beginning, respectively. Still a bug to be fixed there, though.
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Thanks it appears we never offset the errors by the header's length. We've corrected it for the next maintenance release.


Actipro Software Support

Posted 11 years ago by Scott Currie
Avatar
When do you expect that to ship?
Posted 11 years ago by Scott Currie
Avatar
You have an additional bug with Header/Footer and XML.

Intelliprompt prompts are not generated for the first line in the Document when headers and footers are specified. If I just insert a newline so that the first line becomes the second, intelliprompt works.
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
We just had a release last week so it may be a little while yet so we can collect more changes.

Sorry but I'm not seeing the problem with IntelliPrompt, even in build 480. Perhaps you can make a simple sample project that shows that and e-mail it over. Thanks.


Actipro Software Support

Posted 11 years ago by Scott Currie
Avatar
This is a pretty serious bug. It's 2 two your primary advertised features (XML validation and fragment support) that don't work together. Do you have a workaround for the header issue? If not, would it be possible to get a private build with the issue fixed?
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Scott,

Sure we could probably get you a private preview build. E-mail us for it and please reference this post.


Actipro Software Support

Posted 11 years ago by Scott Currie
Avatar
Is a maintenance release with the fixes coming out soon? It's been about 4 months since the last maintenance release.
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Scott,

It's only been about 3 months, but yes, we do plan on doing maintenance releases probably within the next week sometime.


Actipro Software Support

The latest build of this product (v2018.1 build 0341) was released 10 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.