More commands option is not getting enable in QAT drop down

Ribbon for WPF Forum

Posted 11 years ago by Anurodh Ora
Version: 4.5.0482
Avatar
Hi,

I have a problem related to QAT, that the "More Commands..." option is not getting enable at all in the QAT drop down list. Other options like Show Below the Ribbon, and Minimize the Ribbon are working properly.

I have already set the property IsCustomizeQuickAccessToolBarMenuItemVisible="True"
and IsQuickAccessToolBarCustomizationEnabled="True"

I have also gone through the sample application then More commands option is enable but in code I did not get any line which enable/disable it.

Is there any specify way to enable it or what?

Please do reply.

Thanks

Anurodh

[Modified at 02/13/2009 02:59 AM]

Comments (4)

Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Anurodh,

The documentation for the IsCustomizeQuickAccessToolBarMenuItemVisible property has this remark in it:
"When this menu item is made visible, be sure to handle the RibbonCommands.CustomizeQuickAccessToolBar command in your application."

So you need to handle that command. Since you don't have a handler in your code, and the menu item is command-based, it disables right now. Add a command handler and it will enable.


Actipro Software Support

Posted 11 years ago by Anurodh Ora
Avatar
Hi,

Problem did not get solved yet.

I have implemented the command in constructor like


this.CommandBindings.Add(new CommandBinding(RibbonCommands.CustomizeQuickAccessToolBar,
                customizeQuickAccessToolBarCommand_Execute));
and command handler like


private void customizeQuickAccessToolBarCommand_Execute(object sender, ExecutedRoutedEventArgs e)
{
   MessageBox.Show("More Commands Executed");
}

and set property is XAML

IsCustomizeQuickAccessToolBarMenuItemVisible="True"
IsQuickAccessToolBarCustomizationEnabled="True"

but the More commands option is not getting enabled.

Is there any other property to set or code to write.

Please let me know.

Thanks
Anurodh
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Anurodh,

I believe that should work but again, with WPF commands you need to ensure that keyboard focus is somewhere within the object that has your handler. Are you sure keyboard focus is within the control that you added the handler?

If that doesn't help, then please send a simple sample project showing the problem to our support address and reference this post. Thanks.


Actipro Software Support

Posted 11 years ago by Anurodh Ora
Avatar
Hi,

my problem gets resolved.

Thanks

Anurodh
The latest build of this product (v2019.1 build 0683) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.