Bug with HorizontalSplit Starting Line

SyntaxEditor for Windows Forms Forum

Posted 14 years ago by Boyd - Automated Software Testing Consultant / Developer, Patterson Consulting, LLC
Avatar
I've been experiencing this bug for a while, but I was never able to track it down or even rule out that it wasn't something I was doing in my application. I finally found a way to consistently reproduce it in the Sample Application.

1) Open Sample Application (which will load the C# Language by default).
2) Without doing anything, use the 'Language' menu to change the language from C# to HTML.
3) In the HTML document, slide the scrollbar all the way to the bottom of the document (don't move the caret, although I'm not sure it matters). At this point, the first line I see is #19 and the last line I see is #37.
4) From the 'Window' menu, select "Split Horizontally". At this point, the first line in both splits is #19 and the last line is #27 (so far, so good).
5) From the 'Window' menu, select 'No Splits' to turn off splitting. At this point, the view looks like Step 3.
6) Withing doing anything else to the HTML document, use the 'Language' menu to change back to the C# language.
7) In the C# document, slide the scrollbar all the way to the bottom of the document. At this point, the first line I see is #39 and the last line is #57.
8) From the 'Window' menu, select 'Split Horizontally'.

At this point, the first line in the top split is #31 and the top line in the bottom split is #39. These starting line numbers should be the same. In this example that I was able to reproduce, the line numbers aren't off by much at all. In some of the larger documents I've been working with, the difference has been huge (1000+ lines off... strangely enough, the top split had a tendency to start at line #101).

Anyway... I'm glad I was finally able to reproduce this. Hopefully you'll be able to trace down exactly what's causing the problem.

Enjoy! <IMG SRC="biggrin.gif" border="0">

Comments (2)

Posted 14 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Good repro... how the heck did you find that? <IMG SRC="smile.gif" border="0"> It's now fixed for the next release.


Actipro Software Support

Posted 14 years ago by Boyd - Automated Software Testing Consultant / Developer, Patterson Consulting, LLC
Avatar
Glad you were able to track this one down.

I kept stumblining over this issue in one of my applications, but I was never convinced that it wasn't something I was doing wrong. I was switching documents in and out of SyntaxEditor, but maintaining the current SE settings (like split positions) with each document. I always thought it was my manual adjustments of the split position that caused it until I encountered it in my MDI application that didn't include the switching of documents.

Luckily, I was able to reproduce it in the sample app after about 10 different attempts.
The latest build of this product (v2018.1 build 0341) was released 6 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.