Posted 10 years ago by Tsuyoshi Yamashita
Version: 9.1.0501
Avatar
IME doesn't work correctly by SyntaxEditor (for WPF).
Is there any plan to support IME?

It was supported in SyntaxEditor (for WinForms).
=> http://www.actiprosoftware.com/Products/DotNet/WindowsForms/SyntaxEditor/Fonts.aspx

Comments (4)

Posted 10 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Tsuyoshi,

Yes, absolutely. We are implementing similar feature areas one-by-one in the WPF version and will add IME support. We just haven't gotten a chance to do it yet, but it is coming.


Actipro Software Support

Posted 10 years ago by Tsuyoshi Yamashita
Avatar
Does this problem schedule the correction by the 2009.2 version?
This problem is a big reason why SyntaxEditor for WPF cannot be adopted with the product of Japan...
Posted 10 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hello, IME should allow input right now but via a floating toolbar for input. We were able to enter Japanese characters fine with it.

However I assume by this request you mean that you'd like to see the input editor render more "inline" with the text instead of being a floating toolbar, right?


Actipro Software Support

Posted 10 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Just wanted to let you know, we added native IME support to SyntaxEditor for WPF when used in Windows apps (not XBAP) in WPF Studio 2009.2 build 515.


Actipro Software Support

The latest build of this product (v2019.1 build 0683) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.