Assemblies not found in VS2010 'Add Reference'

SyntaxEditor for Windows Forms Forum

Posted 9 years ago by Paul Fuller
Version: 4.0.0285
Platform: Universal Windows Controls
Environment: Windows 7 (32-bit)
Avatar
The SyntaxEditor assemblies are not showing up in the VS2010 'Add Reference' dialog under the .NET tab.

This is on Windows 7 / VS2010 after the following:

- Installed SyntaxEditor V4.0.0285. No issues reported. I changed the target directory from 'C:\Program Files' to 'C:\Programs' as requested in the installer
- Open an existing project, delete old references and try to add them back
- Ditto on a fresh project

Further info:

- The assemblies are in C:\Windows\assembly with the correct version
- There are also V4.0.0282 versioned assemblies in the GAC. Don't know why they weren't removed by the de-installer
- I can add the references via the Browse tab from 'C:\Programs\Actipro Software\...' and 'C:\Program Files\Common Files\Actipro Software\...'
- Other third party DLLs appear in the 'Add Reference' .NET tab as expected.
- Tried SyntaxEditor V4.0.0285 under Vista / VS2008 and the assemblies do appear as expected under 'Add Reference' .Net tab
- Tried SyntaxEditor V4.0.0284 under Windows 7 / VS2010. Same issue

So it looks like a general issue with SyntaxEditor on Windows 7 / VS2010.

Comments (5)

Posted 9 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Paul,

Thanks for posting this. I believe we're missing a registry entry during install that adds support for it in VS 2010. We'll mark down to add this in the next build.


Actipro Software Support

Posted 8 years ago by Markus Lippert
Avatar
Still problems with version 4.0.0287 under Windows 7.

After installing to "C:\Programs\" references are shown.

But:
- I created a new project
- Added SyntaxEditor onto a form (with drag/drop from toolbox)
- SyntaxEditor-Control was visible on form. Everything seems to be ok.
- Compiled the project. => Error occures: Namespace "ActiproSoftware" not found.
- Also in intellisense there is no "ActiproSoftware" namespace
- Then if i want to open the form (doubleclick on form in projectexplorer) VS 2020 crashes.
- Also a restart of the project does not help

I have:
Windows 7
VS 2010

Sincerely
Markus
Posted 8 years ago by Paul Fuller
Avatar
The DLLs still aren't registered for me either as of V4.0.0287 on VS 2010 / Windows 7.

Not really a problem because I know where to 'Browse' for them.

Further to what Markus reports though, I don't see the SyntaxEditor control anywhere in the Toolbox. Again not really a problem because I always build forms through code rather than in the Designer.

Where is it meant to be in the Toolbox ? Is there a re-install in Toolbox option ?
Posted 8 years ago by Markus Lippert
Avatar
Changing the project-setting "target-framework" to ".NET Framework 2.0" (instead of ".NET Framework 4.0 Client Profile") solved the problem.

Sincerely,
Markus
Posted 8 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Markus and Paul,

The problem is that our installer and samples are set up for VS 2008 right now. Our plan is to get things updated to be VS 2010/2008 instead of VS 2008/2005 soon but we got tied up with another project for a bit.

Paul, I would think it would show up in the toolbox if you do "Tools / Choose Toolbox Items" in VS 2010 and pick the assembly. We'll get this fixed though so it's automatic when we get our installer/project updated.

Markus, we don't support Client Profile yet since we have a dependency on System.Design. However you can use ".NET Framework 4.0" (not client profile version) ok.


Actipro Software Support

The latest build of this product (v2018.1 build 0341) was released 3 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.