Posted 9 years ago by Aristo - Senior Team Leader, Petrolink Services
Version: 10.1.0523
Avatar
Hi all,

Currently we are porting our own code to .Net 4, and we are already saw few issues with our own code. I also saw few issue posted here and there related to this. Regarding to this matter, I want to know whether is there any list of known incompatibilities of WPF Studio with .net 4, whether they will be fixed, and whether there is specific dll available for .Net 4 related to WPF Studio and its components.

Comments (6)

Posted 9 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Aristo,

At this time I don't believe we have any known .NET 4 issues in WPF Studio. All known issues have been fixed. We don't have .NET 4-targeted assemblies since the .NET 3.5 SP1-targeted assemblies work fine in .NET 4.


Actipro Software Support

Posted 7 years ago by Peter Idestam-Almquist
Avatar

Do you have any plans to build any version of ActiPro Studio targeting .NET 4.0?

I know it works to run assemblies targeting .NET 3.5 together with .NET 4.0, but it still requires .NET 3.5 to be installed on the machine.

If we would buy a source code license (Blueprint license) could we build ActiPro for .NET 4.0 ourselves or are there any known issues?

Posted 7 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Yes indeed.  We're considering converting WPF Studio 2012.1 to .NET 4.0 as a minimum.  It may still be a month or two out.  If that release isn't converted to .NET 4.0, then the 2012.2 version definitely will be.

I believe we've done tests though where .NET 3.5 was NOT installed on a machine (only .NET 4.0) and our WPF controls still ran fine on it.  So it really shouldn't be an issue.

Yes, you could retarget for .NET 4.0 with the source code and there shouldn't be any issues.


Actipro Software Support

Posted 7 years ago by Aristo - Senior Team Leader, Petrolink Services
Avatar

Peter, as you replied to my old thread, I confirm that the existing .Net 4 issues in ActiPro which was known  to us already fixed before.

We have since moved into .Net 4 already and so far we haven't found any .Net 4 related issue in later ActiPro WPF Studio.

Posted 7 years ago by Peter Idestam-Almquist
Avatar

Thank you Actipro Software Support, for you fast and informative response!

Answer - Posted 7 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Just FYI, with today's 2012.1 release, we now target .NET 4.0 with all our WPF controls.


Actipro Software Support

The latest build of this product (v2019.1 build 0682) was released 3 days ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.