QAT buttons lost when changing language

Ribbon for WPF Forum

Posted 9 years ago by Radu
Version: 11.1.0540
Platform: .NET 4.0
Environment: Windows 7 (32-bit)
Avatar
Hello

We have the following scenario:
- UILanguage = de-DE
- we add some buttons to the QAT
- save config (QAT serialized and put to our config)
- restart app
- UILanguage = en-US
- load config (QAT deserialized without any errors)
- the buttons are gone

We noticed that you save the Label="blahblah" in the QAT config. But "blahblah" is saved localized!!
If we use same language for serialization/deserialization the load/save for QAT buttons works.

As we don't think we can workaround this on our side please provide a fix

Regards
Radu

Comments (5)

Posted 9 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Radu,

Can you please make a new simple sample project that shows this issue and email it to us? We'd need to be able to repro it to try and fixes out. Please don't include any .exe files in the ZIP and rename the .zip file extension so it doesn't get spam blocked.


Actipro Software Support

Posted 9 years ago by Radu
Avatar
Here u can find a sample:

http://hotfile.com/dl/105252620/da75def/QATMultiLanguageBug_src.zip.html

Below are instructions how to reproduce.

- start QATMultiLanguageBug.exe
- add "New", "Save" and "SaveAs" to QAT
- press "Save QAT" (content of QAT will be deserialized to config.xml)
- restart application (content of QAT is as expected)
- press "de-DE" (do not press "Save QAT"!!!)
- restart application (content of QAT is empty)

if we manually modify "Label" property in serialized content (RibbonControlPathItem) the item is loaded well.

Regards
Radu
Posted 9 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Radu,

We tried running your application but didn't see any issues. Perhaps our machines aren't really switching cultures though and are remaining on US English.

I have an idea of a tweak we could make to our code to possibly help. If you'd like to try it out, please write our support address and reference this post and we'll coordinate further there.


Actipro Software Support

Posted 9 years ago by Vanessa Lind
Avatar
Was there a resolution to this thread?

I am experiencing the same issue as described.
Posted 9 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Vanessa,

Our latest official build 542 should have a tweak we made for this, but I don't believe it was ever validated by the other customer as to whether it fixed it or not. We were unable to repro it ourselves.


Actipro Software Support

The latest build of this product (v2019.1 build 0683) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.