LoadBarLayoutFromFile does not load toolbars in proper locat

Bars for Windows Forms Forum

Posted 14 years ago by Michael Janulaitis
Avatar
I am unable to load a layout and have the toolbar or docking forms show up in the correct location. When attempting to use the save layout and load layout in the BarForm sample, I see similar problems. In the sample, I show the 'Format' toolbar and then drag it up above the menu bar. I then save the layout and then reload the layout. The 'Format' toolbar does not show at all.

Comments (3)

Posted 14 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Thanks for the bug report Michael. I've identified the problem and have fixed it for the next maintenance release. In addition, we're making code enhancements to better track what toolbars a toolbar was around when it was last active in the layout. This information will be serialized to the XML layout and should help make things more accurate when redisplaying hidden toolbars.


Actipro Software Support

Posted 14 years ago by Michael Janulaitis
Avatar
What is the ETA for the next build?
Posted 14 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
We can get you a preview build in the next day or so once we get a couple more of the things you emailed us about sorted out.


Actipro Software Support

The latest build of this product (v2018.1 build 0341) was released 9 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.