Minor MarkupLabel Link Drawing Issue

SyntaxEditor for Windows Forms Forum

Posted 13 years ago by Boyd - Automated Software Testing Consultant / Developer, Patterson Consulting, LLC
Avatar
I thought I reported this before, but I can't find the post. I'll post it again to make sure I didn't forget (forgive me if this is a duplicate).

If the hyperlinked text of an item in the MarkupLabel control used by SyntaxEditor contains spaces, the "underline" effect is not drawn for the space. Typically, the entire linked text is underlined. When the spaces don't get underlined, it looks like multiple links instead of one.

Not a big deal, but wanted to make sure you were aware of it. Keep up the excellent work!

Comments (3)

Posted 13 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Boyd,

Yes this is on the TODO list. Thanks!


Actipro Software Support

Posted 13 years ago by Boyd - Automated Software Testing Consultant / Developer, Patterson Consulting, LLC
Avatar
Not sure when it happened, but this is now mostly fixed. All spaces are now drawn with the underline. I've noticed, however, that it's still only the current word that gets highlighted when you click on the link.

So if I had a link titled "this is some text", the entire string will be underlined and drawn in blue. But if I click on the "some" portion of the link, the word "some" is drawn in red while the rest of the link remains blue.

Not a big deal, but thought I'd point that out. To me, the biggie was getting the spaces underlined to make it look like a single link.

Thanks again!
Posted 13 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Thanks for the bug report Boyd. The underline thing was fixed in v1.0.0081 by the way.


Actipro Software Support

The latest build of this product (v2018.1 build 0341) was released 6 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.