Flickering by Resize

Docking/MDI for WPF Forum

Posted 7 years ago by Alexander Rinne
Version: 12.2.0562
Environment: Windows 7 (64-bit)
Avatar

Hello,

when i resize my MainWindow, which contains Actipro's Docking Solution, the Content flicker to left and right.
Have anybody some ideas to fix that problem?

I dont know where i have to search to fix that.

Thanks 

Alex

Comments (8)

Posted 7 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Alex,

We're not aware of any flickering issues other than WPF just performing its standard arrange cycle as the parent window changes size.  If you have complex layouts, sometimes there will be a brief lag while the layout of the content catches up to the new window size, but that isn't anything due to our product.


Actipro Software Support

Posted 7 years ago by maddy
Avatar

Hi Alex,

 

I am also facing the same problem. Whenever I open my Tool Window or dock it in any other docksite. An exactly similar kind of flickering area is produced at the another side of the screen. Problem is that I am also having a WinForms chart host control with Tool window so what i was thinking that problem is because of Winforms chart and WPF tool window integration.

Now as I got to know about your problem ,It seems to be of similar kind.

Hope a solution will be found by ActiPro team soon..

Posted 7 years ago by Alexander Rinne
Avatar

Hi Maddy,

i don't use a WinForm Host Control. I have detected that on an other laptop with the same code base there is no flickering effect.

 

To classify the flickering effect look here: http://youtu.be/K5VudPKL-5U

[Modified 7 years ago]

Posted 7 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Alex,

Can you make a new simple sample project (or maybe just the one in your video) that has the least amount of code needed to make this occur and email that to our support address?  Then we can take a look and see if there's anything we can do.  Please rename the .zip file extension so it doesn't get spam blocked.  Thanks!


Actipro Software Support

Posted 7 years ago by Wilfried Goller
Avatar

Hi Actipro,

we have the same problem. You can easily check this with your sample browser by changing the target framework in your project settings to .NET Framework 4.5 and start the app in the debugger. 

Posted 7 years ago by maddy
Avatar

Hi Wilfried,

We are also facing the same problem and we used WPF Framework 4.5 Beta Version. But finally Microsoft has withdrawn this feature.

How did you solve this problem so if you have any solution ,please recommend accordingly.

Thanks

Posted 7 years ago by Wilfried Goller
Avatar

Hi Actipro,

we have no solution right now :-(

Posted 7 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Wilfried,

I just changed our Sample Browser to target .NET 4.5 and ran it in the debugger in VS 2012 and opened all of the Docking demos.  I don't see any flickering in them though.  I am running on the RTM versions of .NET 4.5 and Windows 8, not a beta.

If you see the problem happening in .NET 4.5 RTM, could you make a new simple sample project that shows it happening for you and e-mail that to our support address, mentioning this post?  Make sure you rename the .zip file extension so it doesn't get spam blocked.  I don't believe we ever got a sample from Alex per our request above.


Actipro Software Support

The latest build of this product (v2018.1 build 0675) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.