Problem

"Unable to start debugging" (Silverlight Trial VS2013)

Posted 4 years ago by Avatar Nathaniel Armer

Hi There,

 

Recently found out about your tools and wanted to check 'em out.  As such I downloaded the latest silverlight toolkit and opened up the C# solution.  However, when I hit debug it gives me a very annoying message:

https://www.dropbox.com/s/1pmz26suol7y71e/Screenshot%202014-07-28%2013.58.33.png

At least I get to see what your support is like :)

I'm running Win7 (in parallels), VS2013.  I have uninstalled everything relating to Silverlight and then installed the developer tools (x64), sdk and toolkit for SL5.  I am new to Silverlight, but have VS and WPF experiance.

 

Thanks!


Comments (3)

Posted 4 years ago by Actipro Software Support - Cleveland, OH, USA

Hi Nathaniel,

Thanks for evaluating our controls.  I'm sorry you are having problems.  From what you show in the screenshot, it appears that it's something that is wrong with your Silverlight SDK in general and nothing specifically related to our products.

I did some searching on the web and found these posts, which seem like they might be similar to your scenario.  Can you try out some of the steps they mention there as answers and see if it helps?  Please let us know.

http://social.msdn.microsoft.com/Forums/silverlight/en-US/4cf10a81-d129-47ab-b88c-c08fb8a2d1d1/cannot-debug-silverlight-project-after-windows-81-update?forum=silverlightstart

http://stackoverflow.com/questions/14964822/visual-studio-keep-asking-to-install-latest-silverlight-developer-runtime-when


Actipro Software Support
Posted 4 years ago by Nathaniel Armer

TL;DR Solved - Mostly a VS issue.

Thanks for your quick reply, your links were informative.  However after following them I failed to see any improvement.

So what I did next was to try build a normal Silverlight application, and I got the same error.  However, this time in the 'debug' section it let me pick my browser.  Unsurprisingly it was defaulting to my parallels 'shared' browser (basically a virtualisation tool that lets me open browser window from my windows vm in my mac host).  I selected one of my VM's browsers and it worked perfectly.

So I go back to your application and I have no option to select a browser :(

Solution?

Create a html file, click 'Browse With' delete the 'shared' browser and select IE.  

Great now it no longer complains, and launches fine.  However immediately there is an error, something about a corrupt manifest?  

Solution, ensure the start-up object is set in project settings.

 

*Phew*

Posted 4 years ago by Actipro Software Support - Cleveland, OH, USA

I'm glad you got it working.  Normally you just install and can instantly compile/run without any changes.  I guess the configuration your system has makes things a bit more complex.


Actipro Software Support

Add a Comment

Please log in to a validated account to post comments.