ActiproSoftware.Docking.Wpf30.Aero2.dll missing

WPF Studio, Themes, and Shared Library for WPF Forum

Posted 4 years ago by bobbyg
Version: 9.1.0507
Avatar

I have an application that I wrote 4 years ago runs fine under Win7 using Actipro Wpf Studio.

However running it in Win8 the XamlParser crashes out looking for the "ActiproSoftware.Docking.Wpf30.Aero2" version : 506" assembly.

This is not part of the WpfStudio that I have and I downloaded the latest one available to me... and it is not in there either.

Where can I get it?

I read somewhere that you can ignore that exception however on Win8 the application just quits at that point.

I attempted to fake it out by changing another ActiproSoftware dll to the same name however the Assemblies version is 507. And Win8 wants version 506.

Is there a way I can fake it out?

Comments (2)

Posted 4 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hello,

WPF will probe for operating system theme resources when encountering control libraries.  Aero2 is what is used by Windows 8 and later by default, if it is found.  Old versions of the Docking/MDI product didn't yet define an Aero2 theme, so Windows 8 will throw that exception, however it can be ignored and the app will continue on normally since it gets caught internally by Microsoft's code.

We've never seen an instance of that cause an actual application crash (due to Microsoft catching it) so I wonder if it's something else causing your crash.  If Microsoft's code did crash on that sort of thing, that would prevent any old apps from ever running on newer operating system versions, and that would never be allowed.

I'd recommend you run your app from within VS and set break on all CLR exceptions on.  See where it is having troubles and what is actually crashing it.

As for the Aero2, there's nothing you can do for that annoying exception with the old version other than ignore it.  If you get a newer version of our products, it will go away since we define that theme there.


Actipro Software Support

Posted 4 years ago by bobbyg
Avatar

I figured it out.

I have embedded the Actipro assemblies in the resources and I am using the AssemblyResolve event.

I removed this event handler and then it worked.

The XamlParser asks for the "Aero2.dll" and when searching the main exe assembly there is no name of that sort embedded in the resources.

The search for the name in the assembly was throwing an invalid parameter name or not found exception which I was not catching.

Once I caught it and returned null for the missing Aero2.dll assembly everything worked.


 

The latest build of this product (v2018.1 build 0675) was released 7 days ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.