Problem

Docking Hints Bug

Posted 3 months ago by Avatar Horacio Jiménez

Hello,

I've just started using your product (2018.1) and found this bug while testing the docking component on Windows 10 with Font and UI scaling turned on (150%).

Notice how the docking hints are missplaced. The furthest right or down the window is placed, the greater the missplacement, eventually making it imposible to reach some of the docking marks.

This didn't happen on the latest 2017.2 version which I tested before finally getting 2018.1.

 

Thanks and regards,

horacio

 

Docking Hints Bug


Comments (4)

Posted 3 months ago by Actipro Software Support - Cleveland, OH, USA

Hi Horacio,

We did update some DPI handling logic for 2018.1 to make it work better with per monitor DPI scenarios. 

I'm trying to reproduce what you are seeing but haven't been able to.  Can you tell me:

1) How many monitors do you have?

2) Which Windows version are you on?

3) After changing DPI did you log out of Windows and back on?

4) You are seeing this in our own sample app without any changes made to it?

Thanks!


Actipro Software Support
Posted 3 months ago by Horacio Jiménez

Hello again,

1. I have two monitors, one FullHd and another 3.something K, but it happens with that just last one plugged in, which is the one I have with scale on.

2. Windows 10 Pro, 1803, build 17134.48

3. I've changed DPI to 100% and back again to 150%, and at 100% it behaves correctly.

4. Yes, as well as with any new project. This is a capture of my full desktop, with just one monitor plugged in (booted like that), and 200% scale.

Docking Hints Bug 2

Mouse was on the bottom docking mark. It seems as if the docking overlay with the marks is missplaced with it's origin offset coords being multiplied by the DPI or something like that, as I told you, the furthest right or down the window is, the larger the missplacement.

 

Thanks and kind regards,

horacio

Posted 3 months ago by Actipro Software Support - Cleveland, OH, USA

Hi Horacio,

Thanks for the info.  We're working on some updates for this that should have it resolved but we'd like to get you to take a look before we roll it out publicly.  Can you write our support address and we'll send you a preview build to test with?  Thanks!


Actipro Software Support
Posted 3 months ago by Horacio Jiménez

Yes, of course. That'd be great, thanks!!

Thanks and kind regards,

horacio

Information The latest build of this product (2018.1 build 0672) was released 27 days ago, which was after the last post in this thread.

Add a Comment

Please log in to a validated account to post comments.