Problem

RibbonWindow WindowState and Rendering Issue

Posted 27 days ago by Avatar Nathan Hanson

Hi all,

I've got a client who is reporting the following:

The window opens maximized on the screen. Everything looks fine. When he clicks the restore down button, the restore down button displays the wrong icon as if its WindowState were still maximized. Then he drags the window around and all the items in the window title area disappear. Same with the items in the status bar. These steps reproduce the issue every time for this particular user.

This has only been reported by one user in the year since we've been shipping with Actipro RibbonWindows. And I can't make the problem happen on any of our internal test systems. I'm kind of stumped. Is there anything you'd recommend I try to test next?

Thanks!

Nate Hanson

UX Developer

Energy Exemplar

Information The latest build of this product (2018.1 build 0672) was released 27 days ago, which was before this thread was created.

Comments (2)

Posted 26 days ago by Actipro Software Support - Cleveland, OH, USA

Hi Nate,

I'm sorry, I haven't heard of that particular problem happening.  I might recommend trying our latest 2018.1 version to see if it makes any difference.  We have made numerous updates to RibbonWindow and the core theme system since the 2016.1 version you mentioned, so I'm curious if any of those get it working for that client.


Actipro Software Support
Posted 26 days ago by Nathan Hanson

No worries. I think you're right. I'll build our next patch against your latest release and see if that helps this particular user. I've only had one user have problems, and all of my test machines work great. So it's tough to chase.

I also save out a lot of window state data and restore it at startup. Maybe I'll have him wipe that data and start fresh to see if that helps. I'll report back on how it goes. Thanks!


Add a Comment

Please log in to a validated account to post comments.