Scrollbar thumb getting invisible when binding large number of items in listview under docking

Docking/MDI for WPF Forum

Posted 10 months ago by Surendra Mudragada
Version: 23.1.2
Avatar

I have a requirement of binding large number of items to listview item source.

In this scenario, scrollbar thumb is getting smaller and smaller and finally invisible.

Could you please check this issue or suggest any workaround to make the scrollbar thumb visible.

Comments (4)

Posted 10 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Hi Surendra,

What you are describing sounds like an issue that was fixed several years ago in v20.1. We tested v23.1.2 that you indicated in your forum post, but are not able to reproduce the issue in that version.

Can you please confirm that you are using at least v20.1 and, if so, can you be more specific about how we can reproduce the issue?


Actipro Software Support

Posted 10 months ago by Surendra Mudragada
Avatar

Hi, We are using version 21.1

To be exact, we are binding objects inside a list view located under docking tool window.

This tool window has options to dock , float

In the start , when data is binded to list view, we are seeing very small scroll bar thumb inside scroll viewer. If we drag the tool window and increase the size we could see the scroll bar thumb size increase gradually. 

When we click on float option in toolwindow and maximise it, again we are not able to see the scroll bar thumb.

Could you please suggest here as we are unable to see the scroll bar thumb.

[Modified 10 months ago]

Posted 10 months ago by Actipro Software Support - Cleveland, OH, USA
Avatar

Just for clarity, normal behavior is for the size of the thumb to shrink as the number of list items grows, but it should never get smaller than about 8 pixel tall in vertical orientation (or 8px wide in horizontal).

Could you please recreate what you are seeing in a simple sample application and send to our support email address? If so, please include the exact steps to reproduce the issue and delete any bin/obj folders from the project before zipping so the attachment doesn't get SPAM blocked.


Actipro Software Support

Posted 8 months ago by Surendra Mudragada
Avatar

Hi ,

I have shared sample application that can replicate the issue along with steps to reproduce via email to your support mail box.

Could you kindly check and share us a solution as this has been pending since long time.

The latest build of this product (v24.1.2) was released 2 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.