Weird Behaviour

Ribbon for WPF Forum

Posted 11 years ago by Matt
Avatar
Since installing latest Actipro 3.5.x and updating project to .Net 3.5 (changed targetting) I come across a really weird behaviour with Combobox opening in the wrong place most of the time? What is even strange is that this behaviour is intermittent, when it starts doing it I resize the browser a cm or so and it will work again for a few drop of the drop downs (most of the time). It may not be related to Actipro but any ideas?

http://img67.imageshack.us/my.php?image=weirdcomboboxcg3.jpg

Comments (5)

Posted 11 years ago by Matt
Avatar
And again so it not limited to combobox.

http://img88.imageshack.us/my.php?image=weirdagaincaptureem5.jpg

This behaviour is on both a Windows 2003 Server TS and on a Vista machine.
Posted 11 years ago by Matt
Avatar
Interesting... Collapse the Navigation Bar or Comment from the page layout and everything is back to normal
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Matt,

Is this the .NET 3.5 SP1 beta or normal .NET 3.5? We haven't heard of popup issues like this yet.

Also are you able to dupe it in the Windows version of our Sample Browser at all?

[Modified at 05/30/2008 08:50 AM]


Actipro Software Support

Posted 11 years ago by Matt
Avatar
Okay fixed it. Phew..

Inside the navigation bar I had a itemscontrol, each item had a datatemplate that looked up the ActualWidth of an ancestor that wasn't actually there. kind of a weird reaction but my bad nonetheless.. removed and all back to normal.

Disregard the video email.
Posted 11 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Phew, you had us scared for a minute. :) Glad you got it working normally.


Actipro Software Support

The latest build of this product (v2018.1 build 0675) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.