Posted 10 years ago by Julian
Version: 4.0.0280
Avatar
Hi

It seems that the framework assemblies are not being reflected with regard to the xml documentation. I have no comments with Parameter Info, Complete Word and Quick Info etc. Every thing works fine for my assemblies.
In the cache folder there is only Reflection.dat files for the framework assemblies, my assemblies have the Documentation.dat files as well, and this I assume is what is missing for the framework assemblies.

I have the same problem with the sample projects.

Any thoughts as to the problem?

Thanks

Julian

Comments (4)

Posted 10 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
It sounds like your XML documentation files for the .NET framework aren't being found. SyntaxEditor will search several locations for them. See if on your system you can find where files like System.xml are and let us know. We can tell you if the path is searched or not.

On my system, it's in:
C:\Windows\Microsoft.NET\Framework\v2.0.50727


Actipro Software Support

Posted 10 years ago by Julian
Avatar
Hi, thanks for the reply.

Mine are here:

C:\Windows\Microsoft.NET\Framework\v2.0.50727\en

Also checked another PC and its the same, but interestingly another PC has none!

Julian
Posted 10 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Julian,

Interesting so they put it in an "en" child namespace. We'll update the next maintenance release to search for them there too. Thanks for posting about this!


Actipro Software Support

Posted 10 years ago by Julian
Avatar
Thanks, I'll keep an eye out for the next release

Julian
The latest build of this product (v2018.1 build 0341) was released 8 months ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.