problems with deployment of Actipro Wizard app

Wizard for WPF Forum

Posted 9 years ago by andy
Avatar
Our Actipro based wizard app does not start after I deploy to a Windows 7, 32-bit test machine.

I've tried copying all the code-signed Actipro DLL's to the same dir as the .exe. No help. I tried copying the Actipro DLL's above the non code-signed DLL's. Still no help. Sorry to say, the only clue I find about the problem is this text from the Windows "Stopped Working" dialog, shown below.

Any ideas on how to successfully deploy Actipro software?

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: <MyWizardName>.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 4c2e63b8
Problem Signature 04: PresentationFramework
Problem Signature 05: 3.0.0.0
Problem Signature 06: 4a174fbc
Problem Signature 07: 624f
Problem Signature 08: e1
Problem Signature 09: System.Windows.Markup.XamlParse
OS Version: 6.1.7600.2.0.0.256.4
Locale ID: 1033

Comments (2)

Posted 9 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
The only time we've really seen startup issues like what you are describing is if the proper .NET framework isn't installed. Are you positive that you have .NET 3.5 SP1 or later installed?

If you do, the next thing to check would be to make sure your app has something to catch unhandled exceptions and log them. If this is an unhandled exception then maybe you didn't set up licensing for our controls correctly per the "Applying WPF Licensing After Purchase" topic. If that was the case, a LicenseException would be thrown.

As long as you set up licensing correctly, all you need to do to deploy an app that uses our controls is to copy the Actipro assemblies you use to the same folder as your .exe. All our controls need the ActiproSoftware.Shared.Wpf351.dll.


Actipro Software Support

Posted 9 years ago by andy
Avatar
Fixed by adding .licx file AND by fixing a problem with my app.

Thanks for the support.
The latest build of this product (v2019.1 build 0681) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.