Disable horizontal scrollviewer without automatic text wrap

SyntaxEditor for WPF Forum

Posted 8 years ago by Tino Schnerwitzki
Version: 11.1.0543
Avatar
Hi,

the standard syntaxeditor (without any text) shows a horizontal scrollviewer altough there is nothing to scroll. One Solution is to set WordWrapMode to "Word" to turn off the scrollviewer. The problem is that text now wraps automatically.

I want to manage the text wrapping (and indent of new lines) by myself with a textformatter.

Is it possible to disable the scrollviewer of the syntaxeditor without enable the automatic text wrapping?

Thanks a lot for any hint.

Comments (1)

Posted 8 years ago by Actipro Software Support - Cleveland, OH, USA
Avatar
Hi Tino,

Sorry there isn't an option for that at this time. I will log your request.

You may be able to run through the control hierarchy and find the ScrollBar in the EditorView's visual tree and change its height to zero or perhaps try to change its Visibility, but we haven't tested that.


Actipro Software Support

The latest build of this product (v2019.1 build 0683) was released 1 month ago, which was after the last post in this thread.

Add Comment

Please log in to a validated account to post comments.